您最多选择25个主题 主题必须以字母或数字开头,可以包含连字符 (-),并且长度不得超过35个字符

81 行
2.5KB

  1. {
  2. "name": "codekoalas/koality-drupal",
  3. "description": "Project template for Drupal 8 projects with composer: with some pre-installed things needed on every site",
  4. "type": "project",
  5. "license": "GPL-2.0+",
  6. "authors": [
  7. {
  8. "name": "",
  9. "role": ""
  10. }
  11. ],
  12. "repositories": [
  13. {
  14. "type": "composer",
  15. "url": "https://packages.drupal.org/8"
  16. }
  17. ],
  18. "require": {
  19. "composer/installers": "^1.2",
  20. "cweagans/composer-patches": "^1.6",
  21. "drupal-composer/drupal-scaffold": "^2.2",
  22. "drupal/config_export_ignore": "^1.0@RC",
  23. "drupal/config_ignore": "^2.1",
  24. "drupal/config_split": "^1.3",
  25. "drupal/config_update": "^1.5",
  26. "drupal/console": "~1.0",
  27. "drupal/core": "~8.0",
  28. "webflo/drupal-finder": "^0.3.0",
  29. "webmozart/path-util": "^2.3"
  30. },
  31. "require-dev": {
  32. "behat/mink": "~1.7",
  33. "behat/mink-goutte-driver": "~1.2",
  34. "jcalderonzumba/gastonjs": "~1.0.2",
  35. "jcalderonzumba/mink-phantomjs-driver": "~0.3.1",
  36. "mikey179/vfsstream": "~1.2",
  37. "phpunit/phpunit": ">=4.8.28 <5",
  38. "symfony/css-selector": "~2.8",
  39. "drupal/console": "~1.0",
  40. "drush/drush": "~8.0"
  41. },
  42. "conflict": {
  43. "drupal/drupal": "*"
  44. },
  45. "minimum-stability": "dev",
  46. "prefer-stable": true,
  47. "config": {
  48. "sort-packages": true
  49. },
  50. "autoload": {
  51. "classmap": [
  52. "scripts/composer/ScriptHandler.php"
  53. ]
  54. },
  55. "scripts": {
  56. "drupal-scaffold": "DrupalComposer\\DrupalScaffold\\Plugin::scaffold",
  57. "pre-install-cmd": [
  58. "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
  59. ],
  60. "pre-update-cmd": [
  61. "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
  62. ],
  63. "post-install-cmd": [
  64. "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
  65. ],
  66. "post-update-cmd": [
  67. "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
  68. ]
  69. },
  70. "extra": {
  71. "installer-paths": {
  72. "docroot/core": ["type:drupal-core"],
  73. "docroot/libraries/{$name}": ["type:drupal-library"],
  74. "docroot/modules/contrib/{$name}": ["type:drupal-module"],
  75. "docroot/profiles/contrib/{$name}": ["type:drupal-profile"],
  76. "docroot/themes/contrib/{$name}": ["type:drupal-theme"],
  77. "drush/contrib/{$name}": ["type:drupal-drush"]
  78. }
  79. }
  80. }